[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: Virtual block devices (vbd) still not working... :-(

> > This refreshes Linux's view of its partition table, and also polls Xen
> > to find out the current parameters of the VBD. Without doing this,
> > Linux will never see the correct capacity for the VBD (it will
> > probably continue to think that it has zero size!).
> Whenever Alex or I have used VDs they've just worked: There's
> no way to populate a vd with a file system unless you can access
> it from domain0, so its obviously been working for some people.
> I wander if it's got something to do with whether the newly
> created virtual disk just happens to have something approximating
> a valid partition table or not?

No, it doesn't. Linux definitely thinks the vbd has zero size so never
even gets to try to read a partition table. 

I followed what you did exactly, and without an explicit poll of Xen
it definitely didn't work. I'd like to see how your machine setup is
different -- for example, are you sure the /dev/vbd* nodes have the
right device numbers? (Should be major = 125, minor =

I'm going to have some more of a look at the blkdev stuff now, but it
would be nice to know how come it's been "working" for you.

 -- Keir

This SF.net email is sponsored by: SF.net Giveback Program.
SourceForge.net hosts over 70,000 Open Source Projects.
See the people who have HELPED US provide better services:
Click here: http://sourceforge.net/supporters.php
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.