[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen & Automated Disk Management for Domains


i tried lvm (vers. 1) with xenU 2.4. i created one group on a raid0-device 
/dev/md/0 (devfs with gentoo) with several lv's for swap and root for virtual 
hosts. on xen0 i can mount and use these devices without any problem, one of 
these device is currently used as swap for xen0. 

i tried to give access with this xmdefaults configuration
(not mounted in vm as root like the name says, only access for later 

disk = [ 'phy:hdb5,hdb5,w' , 'phy:hda6,hda6,w' , 
'phy:/dev/vg0/rootvm101,hdx1,w' ]
disk = [ 'phy:hdb5,hdb5,w' , 'phy:hda6,hda6,w' ]

when trying to start the vm, this error occurs (i modified xmdefaults to accept 
vmid=vm101 like the name of the vm):

root@vm0 vm # xm create -c vmid=vm101
Using config file /etc/xen/xmdefaults
Error: Error creating domain: [Failure instance: Traceback: 
xen.xend.XendError.VmError, vbd: Segments not found: 

the xend-log says following while creation:

[2004-08-07 12:14:15 xend] DEBUG (XendDomainInfo:692) init_domain> Created 
domain=14 name=vm101 memory=61
[2004-08-07 12:14:15 xend] INFO (console:93) Created console id=14 domain=14 
[2004-08-07 12:14:15 xend] DEBUG (XendDomainInfo:1046) Creating vbd dom=14 
uname=phy:hdb5 dev=hdb5
[2004-08-07 12:14:15 xend] DEBUG (XendDomainInfo:1046) Creating vbd dom=14 
uname=phy:hda6 dev=hda6
[2004-08-07 12:14:15 xend] DEBUG (XendDomainInfo:1046) Creating vbd dom=14 
uname=phy:/dev/vg0/rootvm101 dev=hdx1
[2004-08-07 12:14:15 xend] DEBUG (XendDomainInfo:659) Destroying vbds for 
domain 14
[2004-08-07 12:14:15 xend] DEBUG (blkif:339) Destroying blkif domain=14
[2004-08-07 12:14:15 xend] DEBUG (blkif:415) 
>BlkifController>send_be_disconnect> dom=14
[2004-08-07 12:14:15 xend] DEBUG (XendDomainInfo:619) Closing channel to domain 
[2004-08-07 12:14:15 xend] DEBUG (blkif:422) >BlkifController>send_be_destroy> 

i also noticed that changing configuration to 
disk = [ 'phy:hdb5,hdxSWAP,w' , 'phy:hda6,hdxUSR,w' ]
produces also an error like:
Using config file /etc/xen/xmdefaults
Error: Error creating domain: [Failure instance: Traceback: <type 'tuple'>, 
(<twisted.python.failure.Failure exceptions.TypeError>, 1)

output in xend-log is the same.

any hints for this? or is lvm 1 generally not supported which means i have to 

thanks & best regards,
WEB.DE Video-Mail - Sagen Sie mehr mit bewegten Bildern
Informationen unter: http://freemail.web.de/?mc=021199

This SF.Net email is sponsored by OSTG. Have you noticed the changes on
Linux.com, ITManagersJournal and NewsForge in the past few weeks? Now,
one more big change to announce. We are now OSTG- Open Source Technology
Group. Come see the changes on the new OSTG site. www.ostg.com
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.