[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] 2.6.7-xen0 hang on boot

> I'm trying to run today's bitkeeper snapshot with kernel
> 2.6.7 in dom0.  On bootup time it gets past rc.sysinit
> just fine, but after that init fails to switch to runlevel 3.

Do you know what the last snapshot that worked for you with this
file system was?

We've never tried FC3 before (Is it available to download?)

FC2 proved to be a huge pain because of the use of PIC code in
the tls libraries that required a heroic effort by Keir to
develop a new binary rewriter to work around the -ve segment
offset issue (which he checked in earlier today).

Please can you try booting with 'nosegfixup' on the Linux command
line, or just move /lib/tls out of the way.

> Compiling the xen0 kernel with magic sysrq report (should
> that be on by default in defconfig?) shows me that init is
> running every time I press alt-sysrq-p and have caught a
> number of call traces, most involving upcalls but one real
> gem that looks relevant:

[I'll add sysreq support to the defconfig.]

> Things work when I start init=/bin/bash and the normal bootup
> sequence makes it all the way to the end of rc.sysinit.

Phew -- it doesn't sound like the new fixup code is too broken then.
> Things only start failing when init tries to change runlevels.
> I am wondering if there's something special about the way Xen
> has the virtual memory layout, something that could interfere
> with init changing its own commandline or environment...

Hmm. The new tls fixup code grabs a page starting at 4KB in the
VA space...


SF.Net email is sponsored by Shop4tech.com-Lowest price on Blank Media
100pk Sonic DVD-R 4x for only $29 -100pk Sonic DVD+R for only $33
Save 50% off Retail on Ink & Toner - Free Shipping and Free Gift.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.