[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] USB virt 2.6 split driver patch series


  • To: harry <harry@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
  • From: NAHieu <nahieu@xxxxxxxxx>
  • Date: Tue, 22 Nov 2005 10:59:00 +0900
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Tue, 22 Nov 2005 01:58:55 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=Fs89uCOvte/yteU6b8ikJL9UKKB8YQWovzaMgR0kThM6v/0dG5H1Idfi6wd4tpGIsPbPjRrGot+Lmr2ryB8ip3OiseCw31y/fS66/EKP5a+ubXPoUj2nAQIxtx9RY/qJEjq8umzt0u7aVzJyB7GQJ6wju0uA0praDR5KZeSUS44=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

I had a look at xenidc code, and found some code like this:

--
static void xenidc_endpoint_destroy_1(xenidc_callback * callback)
{
        trace();

        {
                xenidc_endpoint_callback *endpoint_callback =
                    container_of(callback, xenidc_endpoint_callback, callback);

                endpoint_callback->destroyed = 1;

                xenidc_work_wake_up();
        }
}
--

Why name it *destroy_1? it is a common practice to name a local
function with _ or __ as prefix. So for example
xenidc_endpoint_destroy_1() should be named
_xenidc_endpoint_destroy_1() or __xenidc_endpoint_destroy_1()

Hieu

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxx
http://lists.xensource.com/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.