[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Xen 3.0.1-4 for Windows XP Professional 64bit on Pentium D 650 CPU

Dear all,

I did not buy MacBook Pro Yonah yet (see the past log about it); rather,
I bought a shop brand computer with Pentium D 650 CPU, 2GB memory, and
400GB HDD. I installed the latest version of Fedora Core 5 DVD iso image
for x86_64 (not i386).

First of all, I tried to use qemu to make the image file
(/home/xen/win-xp-hdd.img) with pc.c.patch or bios.bin for ACPI, which
worked unsuccessfully so far. I'm not sure whether I can use Vmware
Workstation 5.5.1 on Linux instead of qemu to produce the virtual image

Then, alternatively, I tried the Xen 3.0.1 -- because I heard that they
support the VMX daemon utilizing either VNC + LibVNCServer or
SDL/SDL-devel + dev86. I also incorporated latex2html and texi2html,
which SPECS/xenspec of xen-3.0.1-4.src.rpm suggested to install. I tried
both of VNC and SDL by editing the /etc/xen/xmexample.hvm (such as 

memory = 1024
disk = [ 'file:/home/xen/win-xp-hdd.img,ioemu:hda,w' ]
on_poweroff = 'destroy'
on_reboot   = 'destroy'
on_crash    = 'destroy'

), but it did not boot from the CD-ROM of Windows XP Pro 64 bit. I could
see the xm list like the following, but xen do not access to the cdrom
not I could see the installer of Windows on a subwindow.

[root@localhost makoto]# /usr/sbin/xm create /etc/xen/xmexample.hvm
Using config file "/etc/xen/xmexample.hvm".
Started domain ExampleHVMDomain

[root@localhost makoto]# /usr/sbin/xm list
Name                              ID Mem(MiB) VCPUs State  Time(s)
Domain-0                           0      969     2 r-----    58.8
ExampleHVMDomain                   1     1024     1 -b----     0.0

So that I did

[root@localhost makoto]# /usr/sbin/xm reboot 1

and re-inserted the Windows XP SP2 (32bit), but in vain like the

[root@localhost makoto]# /usr/sbin/xm create /etc/xen/xmexample.hvm
Using config file "/etc/xen/xmexample.hvm".
Started domain ExampleHVMDomain
[root@localhost makoto]# /usr/sbin/xm list
Name                              ID Mem(MiB) VCPUs State  Time(s)
Domain-0                           0      969     2 r-----    64.5
ExampleHVMDomain                   2     1024     1 -b----     0.0

Some people of computer Japanese journal report that I need to
re-compile xen to make it compatible with Intel VT (Virtualization
Technology), but it did not make sense for me. They said that I need to
eliminate -Werror from the Makefile, whose flag is not contained in Xen
3.0.1-4 downloaded from yum install;

Package                 Arch       Version          Repository
kernel-xen0             x86_64     2.6.15-1.2054_FC5  core
14 M
kernel-xen0-devel       x86_64     2.6.15-1.2054_FC5  core
4.9 M
kernel-xenU             x86_64     2.6.15-1.2054_FC5  core
5.2 M
kernel-xenU-devel       x86_64     2.6.15-1.2054_FC5  core
4.5 M
xen                     x86_64     3.0.1-4          core
1.3 M
Installing for dependencies:
bridge-utils            x86_64     1.0.6-1.2        core
28 k
hardlink                x86_64     1:1.0-1.21.2     core
9.7 k
sysfsutils              x86_64     1.3.0-1.2.1      core
64 k

Transaction Summary
Install      8 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 30 M
Is this ok [y/N]:

Maybe something it missing with Xen for Win64bit or I'm misunderstanding
some important steps.

I look forward to your help,

Best regards,

Makoto Sakurai

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.