[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [RFC PATCH 30/35] Add generic_page_range() function

Keir Fraser wrote:

On 22 Mar 2006, at 14:33, Keir Fraser wrote:

Okay, can you suggest a better one? That's the best I could come up with that wasn't long winded.

How about apply_to_page_range()?

That would be better.

secondly, I think you confuse our (confusing) terminology: the page
that holds pte_ts is not the pte_page, the pte_page is the page that
a pte points to

What should we call it? Essentially we want to be able to get the physical address of a PTE in some cases, and passing struct page pointer seemed the best way to be able to derive that. I can rename it to something else vaguely plausible if the only problem is the semantic clash with Linux's idiomatic use of pte_page.

Looks like pmd_page is correct?

Yes... although maybe you could just pass the 'pmd_t *'? That's
what a lot of the mm/memory.c code does.

SUSE Labs, Novell Inc.
Send instant messages to your online friends http://au.messenger.yahoo.com

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.