[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] 2.6.16 nor FC5 -xenU kernel will start under 3.0-testing

I tried building a 2.6.16 kernel from -unstable and also the -xenU kernel provided by FC5 and both will not run under 3.0-testing (changeset 8761:484a14acfc26).

The 2.6.16 kernel will start and die with nothing of value in xend.log or xend-debug.log. If I run "xm create name -c" it will say it can't open "/dev/pts/XX" and that is all the information I can provide.

If I try to boot the 2.6.15 FC5 -xenU kernel (and accompanying initrd using the ramdisk config file option) it simply get "Invalid argument" when executing xm create.

Is not the point of a 3.0 branch that kernels compiled for 3.0.x will run under any version or is there new coded added to both of these kernels that prevent it from running under my older version of Xen? I could see a kernel developed for Xen 3.1 not working with 3.0.x, but my impression was 3.0.x were all meant to be compatible with each other (forward and backward).

If this is not meant to work let me know, otherwise I will open up a bug .

Thank you,
Matt Ayres

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.