[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Re: [Xen-devel] Re: switchroot mount failed

  • To: "Keir Fraser" <Keir.Fraser@xxxxxxxxxxxx>
  • From: "vineet chadha" <virtual.chadha@xxxxxxxxx>
  • Date: Wed, 14 Jun 2006 14:13:04 -0700
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Wed, 14 Jun 2006 14:13:45 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; b=hzTld4absMhIERjXXusJCUzJut1iSvKHYXJ2dYSYa5oru/3D3FS1iqsQ49oy7wvjpDXgX/8BW4jz6tCjk1ayJDGAA/UeEiqrtH7lKqIDTC2pO8cNEG17x5WlDY944k+Go+dEmdU2ljJ5KR5bIyAT/ObVtcVj7d598I0ohDFMaew=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Here are links to see for switch root problem ( specifically first link is exactly similar).

I have re-installed OS and xen in my system ( as i messed up  with grub when palying around it and in hope that i will rectify that error). I am not getting same error now but i am getting following error:
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
PCI : Bridge: 0000:01:00:0
  IO window :c000-cfff
  MEM window : fce00000-fcefffff
  PREFETCH window: e0000000-e01fffff
PCI : Bridge: 0000:01:00:2
  IO window :d000-dfff
  MEM window : fcf00000-fcffffff
  PREFETCH window: e0000000-e01fffff
PCI : Bridge: 0000:01:00:0
  IO window :c000-dfff
  MEM window : fce00000-fcefffff
  PREFETCH window: e0000000-e01fffff
I have tried pci=routeirq and apci=off, it still give me error
Yes, I know about noreboot option and I knew module were loaded and detected.
Thanks for helping me out. I have been trying to make xen work on dual core Xeon 2.8GhZ for last two days....and i have to try all options...so i am now not able to replicate same error. I am using Xen 3.0.2-2. Kindly guide me with this current error.
On 6/14/06, Keir Fraser <Keir.Fraser@xxxxxxxxxxxx> wrote:

On 14 Jun 2006, at 21:28, vineet chadha wrote:

> Normal kernel is booting and detecting SCSI disk fine. When i boot in
> Xen mode, it gives this problem. If you put search "switchroot mount
> failed" in Xen user/dev list, u will see this has been a common issuse
> with no solution posted.

I don't see any duplicates from anyone else if I use those search
terms. Perhaps you can provide links to some threads with people having
the same issue as you?

>  Yes, I also believe it is problem with xen kernel not detecting the
> SCSI drivers or something.
> which log file u want me to check.

When the boot fails, do you see any lines of output from the kernel
stating that it has found a block device 'sda'? If the machine reboots
too quickly for you to read then try adding 'noreboot' to Xen's command

-- Keir

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.