[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [Xen-users] xen 3.0.4 and TLS

I am having the same issue with [[ImportError: libxenctrl.so.3.0: cannot handle TLS data]] in Debian Sarge. Please note that this issue has been brought up in
1) Xen-devel as "Problems with XEN 3.0.4 and Python"
2) Xen-users as "xen 3.0.4 and TLS"
It's the same problem and it has not been solved.

The proposed solution (from Keir/Henning in http://lists.xensource.com/archives/html/xen-devel/2006-12/msg01069.html) is to install a TLS-capable glibc. Henning asserted that libc6-xen worked for him so I downloaded it (package glibc_2.3.6.ds1.orig.tar.gz) from Debian. The installation failed with error:
*** No rule to make target `../manual/errno.texi', needed by
`../sysdeps/gnu/errlist.c'. Stop.

Apparantly there is a bug with glibc that causes the build error I am getting (see http://www.mail-archive.com/debian-glibc@xxxxxxxxxxxxxxxx/msg32507.html).

If anyone knows how to get a final solution then your help will be appreciated!


---------[ Received Mail Content ]----------

Subject : Re: [Xen-users] xen 3.0.4 and TLS

Date : Tue, 16 Jan 2007 16:10:12 +0100

From : "Henning Sprang" <henning_sprang@xxxxxx>

To : franck@xxxxxxxxxxxxxxxxx

Cc : xen-users@xxxxxxxxxxxxxxxxxxx

On 1/16/07, Franck wrote:

> [...]

> I've found this

> http://lists.xensource.com/archives/html/xen-devel/2006-12/msg00608.html

> :(

> Not good for my problem :(

You could try usinf the libc6-xen from Edgy, or Debian

testing/unstable, or look if there's a Dapper backport somwehere.

If you don't get any nosegneg TLS for Dapper anywhere, It's possible

that this change makes xen 3.0.4 impossible to work on Dapper,




Xen-users mailing list



Free Movies 100's of Free Feature Length Films - Meet Friends, Watch Movies & Win!
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.