[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Running Windows 2k3 guest in ACPI multi-processor HAL mode (acpi=1)

  • To: <xen-devel@xxxxxxxxxxxxxxxxxxx>
  • From: Julian Pawlowski <lists@xxxxxxxxxxxxxxx>
  • Date: Mon, 12 Mar 2007 09:20:17 +0100
  • Delivery-date: Mon, 12 Mar 2007 01:30:05 -0700
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: Acdj+G1Kq/fW+M/rEduBTAAX8vMDhQAhtbVt
  • Thread-topic: Running Windows 2k3 guest in ACPI multi-processor HAL mode (acpi=1)

Hey guys,

I'm using standard openSUSE 10.2 Xen installation and would like to start a
Windows 2003 Server as guest with SMP support. So Windows would have to be
in ACPI-Multi-Processor HAL mode to support SMP correctly.

Unfortunately the virtual machine crashes every time I try to start the
installation of Windows with acpi=1 in the hvm configuration file. The blue
installation screen appears and a few seconds later the machine dies, I
guess it is the time when Windows Setup loads the ACPI supporting driver.

Installation with acpi=0 just works fine but of course the later machine has
no SMP enabled and therefore is not able to use the 4 assigned processor
cores. I just tried to replace the hal.sll in c:\windows\system32 with the
correct one with ACPI-SMP support and changed acpi=0 to acpi=1 in the vm
configuration file. Still no luck, the machine dies right after the windows
bootscreen appears :-(

So, how can I solve this?
Would it be better with Xen 3.0.4 as the openSUSE 10.2 standard is still
3.0.3 (with some modifications from Novell I think)?

Thanks a lot for your support!


Julian Pawlowski

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.