[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] 3w-xxxx module problems with Xen

I'm having a problem with getting Xen up and running. My root partition
is on a RAID array connected to a 3ware board. I've run 2.4.22 through
2.6.18 kernel builds with my root on this same board with no problem.

However, when trying to boot into Xen (as dom0), I get the following
error at boot time:

3w-xxxx: Failed to get io address.

The module is loaded, but my card never gets recognized and no drives
show up. As a result, the boot fails. I've tried using the Debian-built
Xen kernels for 2.6.17 and 2.6.18 for both amd64 and i686 with no luck.

I tried downloading the 3.0.3 and 3.0.4 tarballs (64-bit) from xensource
and had the exact same problem at bootup.

I've tried building 3.0.3 from source, and still the same problem.

I found an old (2004) post on xen-devel regarding some 3ware card
problems which mentioned some different boot options to try:

ignorebiostables, noacpi, nosmp, acpi=off, pci=noacpi

I've tried them all with no luck. I really don't know what else to check
or where else to look. Any suggestions would be greatly appreciated.

Alex Malinovich
Support Free Software, delete your Windows partition TODAY!
Encrypted mail preferred. You can get my public key from any of the
pgp.net keyservers. Key ID: A6D24837

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.