[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] [PATCH][SVM]Rename reset_to_realmode.

  • To: xen-devel@xxxxxxxxxxxxxxxxxxx
  • From: "Petersson, Mats" <Mats.Petersson@xxxxxxx>
  • Date: Fri, 23 Mar 2007 12:22:00 +0100
  • Delivery-date: Fri, 23 Mar 2007 04:21:10 -0700
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: AcdtPXl33fU38XU1S9S4ckJzAsqg8A==
  • Thread-topic: [PATCH][SVM]Rename reset_to_realmode.

The current name "svm_do_vmmcall_reset_to_realmode" is misleading, as
there's no involvement of VMMCALL in the single usage of this function. 

I also made it a bit easier to read the code by not using the long form
to access the VMCB in svm_init_ap_context().

The patch also fixes one "space on the end of comment line" and a
miss-spelling of "physical". 

There is no functional change in this code, and I've tested SMP Vista64
with this for a few days.

Applies to c/s 14489. 

Signed off by: Mats Petersson (mats.petersson@xxxxxxx). 


Attachment: patch.rename_reset_to_realmode
Description: patch.rename_reset_to_realmode

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.