[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xway issues / bugs


Sorry you're having trouble with xway.  I've not tried it myself and I've also 
not known of anyone else actually running it...  It might be a good idea to 
try and contact the xway developers directly in case they don't read this 
list, or you could cc them on these e-mails..

Perhaps there's a contact e-mail address for the developers somewhere in the 
source code?

I have a Powerpoint presentation on Xway that I downloaded when it was first 
announced; the presentation was by "Kangho Kim, System Software Team, ETRI".  
ETRI = Electronics and Telecommunications Research Institute.  Maybe you can 
find some contact details for him through Google?


> Dear Developers,
> I have tried using the interdomain communication patch for xen (Xway,
> http://sourceforge.net/projects/xway) a link of which is there at Xen wiki.
> I am having troubles getting it going. I am using AMD Opteron 248 (64-bit),
> with 2 GHz ram and IWILL motherboard. My distribution is ubuntu 7.04 and I
> am using Xen 3.0.3 for i686, as xway patch suggests that it is only for 32
> bit systems. The GCC version is 4.1.2. I have also tried  xway on another
> machine which has 32 bit intel processor. During the boot time, i see in
> the dmesg output giving me "net/ipv4/xway_proto.c:xsw_accept:143:
> inet_accept() err=-11" on Opteron. The intel 32 bit gives NO message of
> this type. Now to the heart of the issue I can get the xway daemon and
> other related stuff loaded without any errors or warning. Upon simple ssh
> from one domU to another (i have compiled the ip addresses as instructed) i
> get a printf on screen on the receiving domain "client_sock = 5" and that
> is where both the domains stop processing i.e. ssh doe not seem to progress
> any further. strace is not helping me that much. I have noticed that
> xwayd.c (daemon) gives a write() call and this call is returning 0, instead
> of the message size.
> Has anyone ever come across this error/bug? or simply has anyone ever tried
> xway?
> Best Regards,
> Atif
> ___________________________________________________________________________
>_________ Looking for last minute shopping deals?
> Find them fast with Yahoo! Search. 
> http://tools.search.yahoo.com/newsearch/category.php?category=shopping

Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.