[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] x86-64 machine with FC8 not booting

  • To: Stefan Berger <stefanb@xxxxxxxxxx>
  • From: Deuce <the_deuce@xxxxxxxxx>
  • Date: Wed, 9 Jan 2008 11:10:13 -0800 (PST)
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, "You, Yongkang" <yongkang.you@xxxxxxxxx>
  • Delivery-date: Wed, 09 Jan 2008 11:11:00 -0800
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:Cc:MIME-Version:Content-Type:Message-ID; b=1oZWCLFMAeFfZMg1CTbWs6/VDi5VFsHQ/KVkqCxqFeCyUHzUHmpjn12sKoW33n3JCGiixubhD/R7xbxmK1ny37fSkob0TVxVKGMLmGitZoxwkYvTdNiDYyyxM/P4utjXiEbtOPvxMr6DuLibQKKIYpAboGPIMB/QKtukCpb7aHQ=;
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>


This says it's related to the lack of sys_ppoll.

These two patches applied to linux-2.6.18-xen.hg and let me boot a xen0 kernel:


----- Original Message ----
From: Stefan Berger <stefanb@xxxxxxxxxx>
To: Deuce <the_deuce@xxxxxxxxx>
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx; "You, Yongkang" <yongkang.you@xxxxxxxxx>
Sent: Wednesday, January 9, 2008 11:57:42 AM
Subject: Re: [Xen-devel] x86-64 machine with FC8 not booting

xen-devel-bounces@xxxxxxxxxxxxxxxxxxx wrote on 01/09/2008 11:22:23 AM:

> I have the hang booting Dom0 which I believe is what Stefan is
> talking about.  Changeset 16678 a.k.a. 3.2.0-rc4.
> It hangs on "mount -o mode=0755 -t tmpfs /dev /dev", the first
> command in the initrd's init after "echo Creating /dev"

I just tried the combination of cs 16421 and cs 309 (Linux). I am sure this worked with FC7, but now also hangs under FC8.


> Jason

> ----- Original Message ----
> From: "You, Yongkang" <yongkang.you@xxxxxxxxx>
> To: Stefan Berger <stefanb@xxxxxxxxxx>; xen-devel@xxxxxxxxxxxxxxxxxxx
> Sent: Wednesday, January 9, 2008 11:17:39 AM
> Subject: RE: [Xen-devel] x86-64 machine with FC8 not booting

> Berger,
> You can also try to use timer_mode=1 or timer_mode=2 in HVM domain config.
> I used to meet some Linux OS hang at booting udev. After set
> timer_mode, it can boot okay.

> Best Regards,
> Yongkang You
> From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-devel-
> bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Stefan Berger
> Sent: Wednesday, January 09, 2008 11:05 PM
> To: xen-devel@xxxxxxxxxxxxxxxxxxx
> Subject: [Xen-devel] x86-64 machine with FC8 not booting

> I have an x86-64 machine that I recently update from an older
> changesets of Xen (16427) and Linux to the most recent ones. It does
> not boot with FC8 on it and hangs while booting after
> Mounting  proc filesystem
> Mounting sysfs filesystem
> Creating /dev
> -> hang
> Does anybody else see the same problem?
>    Stefan

> Looking for last minute shopping deals? Find them fast with Yahoo! Search.
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Never miss a thing. Make Yahoo your homepage.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.