[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH][HVM] pass-through PCI device hotplug support

On 24/1/08 18:06, "Daniel P. Berrange" <berrange@xxxxxxxxxx> wrote:

> IMHO we shouldn't have a 'd' on the front of the command names. VT-d is a
> vendor specific implementation whose nomenculture doesn't need to be exposed
> to users. In addition the existing block & network hotplug commands use
> 'attach' and 'detach' for their command names. So for sake of consistency
> I'd recommend command names of:
>   pci-list
>   pci-attach
>   pci-detach
> I think it is useful to use the same unique naming & data for both attach and
> detach operations. So if we use a (bus,slot,func) triple for attachment, I
> think we should use the same (bus,slot,func) triple for detachment too,
> rather than having to make apps / users lookup the dynamically-allocated
> 'ID' value for the device.


 -- Keir

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.