[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen 3.1.0 on sles10sp1

"Jan Beulich" <jbeulich@xxxxxxxxxx> wrote: 
> The error message clearly indicates that you've got a broken /init in your
> initrd. I guess you'll need to examine what went wrong during its 

I just did that. 
For some reason there was an 
if [ "$caps" != "${caps%control_d*}" ]; then
        echo nothing

I added the "echo nothing" into the if statement, then it worked. After 
restarting again, it panicked again, but now because of missing cciss HDD 
controler driver to access the root partition. I added this and it is 
starting now.
Sorry for the noise.


> Jan
> >>> "Sebastian Reitenbach" <sebastia@xxxxxxxxxxxxxxxxxxxx> 30.01.08 10:02 
> Hi,
> I downloaded the xen 3.1.0 tarballs for 64Bit SMP to install it on a HP 
> DL365 AMD64. After ./install, I added this to the grub menu.lst:
> title XenSource-XEN (2.6.18-xen-3.1)
>         root (hd0,0)
>         kernel /boot/xen-3.1.0.gz
>         module /boot/vmlinuz-2.6.18-xen ro root=/dev/cciss/c0d0p1
>         module /boot/initrd-2.6.18-xen
> Additionally I had to run mkinitrd, as there was no initrd for that kernel 
> after the ./install. Nevertheless, after reboot it ended in a kernel 
> "Screenshot" of the panic is attached, and can also be found here:
> https://www.l00-bugdead-prods.de/Image033.jpg 
> I ran a depmod and mkinitrd. Then after reboot, the boot process ended in 
> panic, see attached screenshot. 
> Any hint what is going wrong here? Further in the README, there is still 
> 3.0 and Kernel 2.16 mentioned, which should be Xen 3.1 and Kernel 2.18.
> cheers
> Sebastian
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx 
> http://lists.xensource.com/xen-devel

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.