[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [PATCH 0 of 4] mm+paravirt+xen: add pte read-modify-write abstraction



Linus Torvalds wrote:
On Fri, 23 May 2008, Jeremy Fitzhardinge wrote:
This series adds the pte_rmw_start() and pte_rmw_commit() operations,
which change this sequence to:

        ptent = pte_rmw_start(mm, addr, pte);
        ptent = pte_modify(ptent, newprot);
        /* ... */
        pte_rmw_commit(mm, addr, pte, ptent);

Can you please rename these.

It's not a general "read-modify-write" operation on the PTE, and this *only* works for changing protection details. In particular, you cannot use pte_rmw_start/commit to change the actual page. So it's very much about just protection bits.

Well, you could use it to update the page and protection bits while preserving the AD bits, but I don't think that's very useful.

It should probably also be called ptep_xyz(), since it takes a pte pointer, not a pte.

So maybe calling it "ptent = ptep_modify_prot_start(..)" ... "ptep_modify_prot_commit(..)" or something.

Yep, sounds fine to me.

   J


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxx
http://lists.xensource.com/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.