[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] floppy image under 3.3

  • To: <xen-devel@xxxxxxxxxxxxxxxxxxx>
  • From: "James Harper" <james.harper@xxxxxxxxxxxxxxxx>
  • Date: Sat, 6 Dec 2008 20:25:41 +1100
  • Delivery-date: Sat, 06 Dec 2008 01:26:11 -0800
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: AclXaNASedTkTD0bRK+lxn55L2Hs+QAGy15A
  • Thread-topic: floppy image under 3.3

> I just tried booting a HVM domain with 'fda=/images/floppy.img' in
> the config, and I get this in the logfile:
> qemu: could not open disk image /installmedia/IDR/floppy.img
> Can anyone tell me what is wrong? It worked under 3.2. The file is the
> correct length (1474560) and permissions.

I'm posting this into dev as I think there is a problem with the code...

In qemu, drive_init calls bdrv_open2, which calls find_image_format,
which calls bdrv_open2, which succeeds. find_image_format appears to
fail though, causing the original bdrv_open2 to fail, giving me my error

Is this roughly what is supposed to happen? I'm continuing to debug but
if anyone can tell me that I'm doing something wrong, or has already
fixed this bug then please stop me :)



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.