[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: pv_ops dom0 USB fixed

  • To: "Jeremy Fitzhardinge" <jeremy@xxxxxxxx>
  • From: "Todd Deshane" <deshantm@xxxxxxxxx>
  • Date: Sat, 13 Dec 2008 13:20:31 -0500
  • Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, Aviv Grafi <aviv@xxxxxxxxxxxx>, Ian Campbell <Ian.Campbell@xxxxxxxxxx>
  • Delivery-date: Sat, 13 Dec 2008 10:21:15 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:reply-to:to:subject:cc:in-reply-to :mime-version:content-type:references; b=u774gmxh56N1Oak5SVTUPsTo8E27dGKolJFtGC0J3a75nIiaFhBsfxaRW0SkPqS9Hz 59VOIdfcvj2VYFcMN78qvCFB01OOwVcAs0h65+O1OT/yKdVJtM0NM2s4zvL8CoqlrYD+ BsqETT4tE4ejeeaUayhnwVrY79OrBlgjLEZK4=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

On Thu, Dec 11, 2008 at 5:38 PM, Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:
> Todd Deshane wrote:
>> disk only, took out vif and dhcp options.
>> Still didn't boot, same error.
>> Log attached.
>> Also changing for 20 to 256 memory gave problems.
>> Looks like some sort of memory problem too.
> Hm, seems to be trying to shrink dom0 too much.  What's your domain config
> file?

kernel = "/boot/vmlinuz-2.6.28-rc8-tip"
ramdisk = "/boot/initrd.img-2.6.28-rc8-tip"
memory = "256"
name = "ubuntu-hardy-jailtime"
disk = ['tap:aio:/home/deshantm/ubuntu.8-04.64.img,sda1,w']
root = "/dev/sda1 ro"
extra = "xencons=tty"

I also tried file:/ for the disk

Same errors.

I poke around a little more in the xen logs to see if I can find any more
useful info on the guest problem

> mem=3G is probably overkill.  There's no problem in Xen using all your
> memory, but you should set dom0_mem=1G or something (less than 3G, but you
> probably don't need all that much).  How much memory does your system have?

I put the dom0_mem down to 512M for now, that should do.

I think that mem=3G is still necessary. I'll send some vtd logs that show it
crash without mem=3G and not crash with mem=3G

>> Also, it looks like I am getting a number of errors in
>> xend-debug.log to do with scsi commands.
>> I will try to track down potentially missing packages.
>> Any idea on what dependencies there might be?
> Looks like you're missing lsscsi and udev (though I would have thought
> Ubuntu would be using udev).

I fixed the lsscsi problem previously (earlier testing).
udev is installed. There may be some issue with its working with
the dom0 kernel though. I have seen the error messages
of /sbin/scsi_id: not found

> BTW, I just pushed up a patch which should clear up the warnings in your
> boot messages (they could potentially result in a system-locking deadlock,
> so its probably worthwhile).

I just pulled the latest patches. The vga is closer to working. I don't see
the kernel boot messages, but I do get a login prompt (text only).
Which works.

My Xorg logs (a working one and a non working one) are attached.


Todd Deshane

Attachment: Xorg-errorlog1
Description: Binary data

Attachment: Xorg.0.log
Description: Text Data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.