[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: Problem with Xen 4.1 on Ubuntu 11.10 ( Oneiric Ocelot) (HVM DomUs crash)

I downloaded and installed  source . Went to  xen-4.0.1/debian/patches.
It contains *.patch  and *.diff files listed in file series ( to apply) .

First i tried
# cat  *.patch | grep hvmloader
# cat   *.diff     | grep hvmloader

All what i was able find :-

In file tools-python-xen-relative-path.diff

         elif vals.kernel == 'hvmloader':
             # Keep hvmloader w/o a path and let xend find it.
-        elif vals.loader == 'hvmloader':
+        if vals.loader == 'hvmloader':
             # Keep hvmloader w/o a path and let xend find it.
                 # Old configs may have hvmloader set as PV_kernel param
                     if self['PV_kernel'] == 'hvmloader':
-                        self['PV_kernel'] = auxbin.pathTo("hvmloader")
+                        self['PV_kernel'] = auxbin.path_boot("hvmloader")
-                    self['platform']['loader'] = auxbin.pathTo("hvmloader")
+                    self['platform']['loader'] = auxbin.path_boot("hvmloader")
             elif self['platform']['loader'] == 'hvmloader':
-                self['platform']['loader'] = auxbin.pathTo("hvmloader")
+                self['platform']['loader'] = auxbin.path_boot("hvmloader")

So, Ubuntu doesn't touch original source of "hvmloader" coming with  xen-4.1.0.tar.gz


--- On Tue, 7/19/11, Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx> wrote:

From: Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx>
Subject: [Xen-devel] Re: Problem with Xen 4.1 on Ubuntu 11.10 ( Oneiric Ocelot) (HVM DomUs crash)
To: "Stefano Stabellini" <Stefano.Stabellini@xxxxxxxxxxxxx>
Cc: "Boris Derzhavets" <bderzhavets@xxxxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>, "Keir Fraser" <keir@xxxxxxx>, "Konrad Rzeszutek Wilk" <konrad.wilk@xxxxxxxxxx>
Date: Tuesday, July 19, 2011, 2:01 PM

On Tue, 19 Jul 2011, Stefano Stabellini wrote:
> On Tue, 19 Jul 2011, Boris Derzhavets wrote:
> > Alpha 2 already has Xen 4.1 packaged and ready for testing.
> > It appears to be known bug that HVM  DomUs crash at Xen 4.1 Dom0 with different "pvops''
> > kernels ( in particular 3.0.0-5-generic Ubuntu) , but not only on Ubuntu .
> > Here is report for Fedora 15 :
> >
> > http://www.gossamer-threads.com/lists/xen/users/213049?nohighlight=1#213049
> >
> > Ubuntu developers are pretty sure that Xen Host will be built with no problems.
> > Would it  be possible to issue a patch for Xen  4.1 to fix the  problem ?
> > Actually two distros are affected Fedora 16 and Ubuntu 11.10 ( maybe Debian  - here
> > i am not sure )
> First we need to understand what the problem is. I wasn't aware of this
> issue before you started a thread yesterday and nothing meaningful
> appears in any of the logs posted.
> Now I am trying to reproduce the problem but so far I didn't have any
> luck: I am testing with the same kernel config and VM config you use
> with plain Linux 3.0.0 rc7, I tried both xen 4.1.0 and xen 4.1.1 but I
> still can start hvm guests with no troubles.
> However all my tests are on Debian 6.0.1, I am downloading alpha 2 to
> see if I can reproduce the bug there.

I managed to repro the issue on alpha 2.
These are the error logs that I get on the xen serial when starting an
HVM guest:

(XEN) HVM1: HVM Loader
(XEN) io.c:194:d1 MMIO emulation failed @ 0018:9ffff: 00 e0 de be 00 83
(XEN) hvm.c:1099:d1 Triple fault on VCPU0 - invoking HVM system reset.

The problem appears to be hvmloader, in fact I replaced the hvmloader
that comes with ubuntu alpha 2 with the one I compiled myself out of xen
4.1.1 and everything worked as expected.
Do you have any patches to xen that might have broken hvmloader?

-----Inline Attachment Follows-----

Xen-devel mailing list
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.