[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] virbr0/bridge: No such file or directory


Would it be possible for you to update your tutorial at: 
http://wiki.xensource.com/xenwiki/RHEL6Xen4Tutorial and create a patch file to 
take care of this Xen bridge issue?

Per your suggestion, I tried mayoung's el6 xendom0 kernel rpm: 
kernel-2.6.32-131.6.1.el6.xendom0.i686.rpm but, the server won't boot.


I tried to compile its src file: kernel-2.6.32-131.6.1.el6.xendom0.src.rpm, the 
system returned many errors and then halted at:  + make -s ARCH=i386 V=1 -j4 

(see attached copy of building errors)


Yur help is greatly appreciated.


> > Those errors are related to the bridge-utils rpm version..
> > There is a workaround documented somewhere.. probably on centos mailinglist.
> > 
> or actually it's because the stock rhel6 kernel includes some patch to 
> kernel bridging code so rhel6 bridge-utils rpm had to be patched for the 
> kernel change.
> so when you use xen.git 2.6.32 kernel (which is not based on rhel6 kernel) 
> you don't have
> the kernel change for bridging and the patched bridge-utils rpm doesn't work 
> anymore.
> Try using mayoung's el6 xendom0 kernel rpm.. it *is* based on rhel6 kernel so 
> it includes the bridging patch.
> -- Pasi

Attachment: el6_errors.txt
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.