[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [Xen-users] XEN 4.1.1 + IGD passthrough and Intel DQ67SW, i7-2600


I have now tried with the new 3.1.0-rc3 kernel (and latest 4.2 XEN), with the exact same result. It passthrough works fine before loading the proper drivers, but hangs at startup with correct drivers.

I forgot to mention that I did try to install Win 7 on this computer without XEN and everything worked fine, so the drivers provided by Intel do work.


On 08/28/2011 12:15 PM, Pasi Kärkkäinen wrote:
On Sat, Aug 27, 2011 at 08:51:40PM +0200, Erik Lind wrote:
Hi Pasi,
and thank you for your reply.

Currently I use Debian squeeze as Dom0,
I use a kernel from the devel/xen-pciback-0.6.1 branch at
git.kernel.org/?p=linux/kernel/git/konrad/xen.git. It is a 3.0.0-rc4
based kernel.

I have been trying for the last day to get some other Dom0 kernel to
work but I have so far been unable to get the pciback module to work on
those kernels (such as the master branch or stable/2.6.39.x). I do
prefer a fairly late kernel to get problem support for the motherboard
and cpu.

Did you try latest upstream Linux 3.1-rc3+ ? it includes xen-pciback.

I have been using a few different Intel drivers, the ones included in
Windows 7 which are from March and newer ones ( from mid August) but
with the same result.

Ok. Maybe Intel developers can comment which driver version should work with 

I have been trying with a few different boot options, but the last try
was with the most basic configuration possible. (included as

Also included is the somewhat messy vm config file, xen_htpc1.cfg.gz

I have included startup logs for two different runs, one with Windows
standard vga drivers (taged with svga_) and with Intel drivers (taged
with intel_). Not sure if that gives any further clues.

I also added info from lspci -vv.

-- Pasi


On 08/26/2011 03:31 PM, Pasi Kärkkäinen wrote:
On Sat, Aug 20, 2011 at 01:59:07PM +0200, Erik Lind wrote:


added xen-devel to cc.

I'm running XEN 4.1.1 (have tested 4.2 unstable too) and I'm trying to
do graphics passthrough of my on board/chip GPU.

What distro is dom0? and what dom0 kernel?

I have been struggling for quite some time without success.

Passthrough as such does work but when loading the proper drivers for
the GPU it does not, and then Windows just stops loading.

What version of Intel gfx drivers?

First attempt was to use Windows 7, I did try both 32 and 64 bit
versions and it did not work.

Then I did an attempt with XP 32bit and to much surprise it did work (at
least it starts up properly haven't tested it that much yet).

After that I tried with Vista 32 bit, just to see, and it did not work.

In short I suppose there is some issue with the gfx drivers for Vista
and Windows 7 or possibly there is some other difference between the
OS:es. Or is it just something else that I'm missing?

Has anyone been able to get XEN and IGD passthrough to work with proper
drivers in Windows 7 and fairly new HW? Any suggestions how to proceed
with troubleshooting?

Thanks in advance

Please also post your grub.conf entry and /etc/xen/<vm>   cfgfile!

-- Pasi

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.