[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] [PATCH v2 0/9] Rename/remove IS_PRIV



Following the conversion of most IS_PRIV hooks to XSM, the remaining
references to this function generally deal with direct hardware access
and not with the type of privilege checks that are best controlled by
XSM. To reflect this, the IS_PRIV check is renamed to is_hardware_domain
and is used only when dealing with accesses that are both required by
dom0 and where it does not make sense to grant access to a domain other
than dom0.

There are a number of existing places in the hypervisor that check
domain_id for equality to zero to make some distinction on dom0; this
series replaces these checks with is_hardware_domain to be consistent in
how the hypervisor checks a domain's access.

The first three patches have been posted before; the rest are new. I
have boot-tested the change on x86 (with PV domains), but have not
compile-tested on ARM.

Cleanup of IS_PRIV checks that should not be is_hardware_domain:
    [PATCH 1/9] xen/arch/x86: remove IS_PRIV access check bypasses
    [PATCH 2/9] xen/xsm: add hooks for claim
    [PATCH 3/9] hvm: convert access check for nested HVM to XSM
    [PATCH 4/9] xen/arch/x86: remove IS_PRIV_FOR references
    [PATCH 5/9] xen/arch/arm: remove rcu_lock_target_domain_by_id

Replace remaining calls to IS_PRIV:
    [PATCH 6/9] xen: rename IS_PRIV to is_hardware_domain

Use is_hardware_domain locations where (domid == 0) was used:
    [PATCH 7/9] xen: use domid check in is_hardware_domain
    [PATCH 8/9] xen/arch/x86: use is_hardware_domain instead of domid ==
    [PATCH 9/9] IOMMU: use is_hardware_domain instead of domid == 0

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.