[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen 4.3 development update RC2 imminent

Il 22/05/2013 18:54, George Dunlap ha scritto:
On 22/05/13 17:30, Pasi Kärkkäinen wrote:
On Wed, May 22, 2013 at 04:05:27PM +0100, George Dunlap wrote:
The emulator in the hypervisor can handle simple SSE instructions
like the above quite well. It's not immediately clear to me why
hvmemul_do_io() would need to limit the size to no more than a
long's width. Perhaps the data passing to the device model may
need adjustment to accommodate wider entities...
Hmm, but the code seems to indicate that the DM can handle wider
entities, by "reading all ones":

         if ( dir == IOREQ_READ )
             memset(p_data, ~0, size);

Anthony, do you want to try making that size check one size bigger
(e.g., allow it to be 16 or 32)?
No, that obviously won't work, because of the line just following:

    if ( (p_data != NULL) && (dir == IOREQ_WRITE) )
        memcpy(&value, p_data, size);
        p_data = NULL;

value is of size "long", so this won't work.

Thanks for help to solve this problem.
Are there news about?

Probably this is a stupid question: is this patch related to that
No, I'm afraid that has nothing to do with this issue.  I've only
looked briefly at it, but it appears that the interface between Xen
and qemu is limited to MMIO accesses of 8 bytes; changing that
interface is not something we can really do while we're in the
middle of doing a release.

The only work-around that would be suitable for 4.3 would be if we
could find an option to tell the X server not to execute SSE
instructions.  If there is no such work-around, then I'm afraid
we're going to have to disable the interface for 4.3.  We'll put it
on the list of work items for 4.4.

Hmm, for testing, can we use cpuid to mask out SSE,
and then try qxl ?

That had occurred to me -- Andrew / Jan, do you know which flag might disable this particular instruction?

I guess we could try just disabling all the SSE instructions.

Fabio: Can you do the following:
* On your host, do "cat /proc/cpuinfo". Under "flags" there will be a big list. Look for all of the ones that have "sse" in them.

On my AMD box, that includes sse, sse2, ssse3, sse4_1, and sse4_2.

* In your xl.cfg, add a cpuid with each of those flags disabled.

On my box, it looks like this:


Then run your system with Anthony's patch and see if you still get the crash.

Thanks, I tried it. On windows domU I get a blu screen with "stop 5d" (even without qxl set) and on linux domU the domU crashes without showing errors on qemu log.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.