[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] how does domU fills io_buffer for ide (QEMU HARDDISK)


    I observe  "ata1.00: failed command: DATA SET MANAGEMENT " on dmo-0 dmesg and I understand that this is because domU (which is win7 in my case ) is sending TRIM command down to the emulated IDE HDD and the range of LBA which we get in s->io_buffer is not appropriate.

I tried to dump the s->io_buffer and I notice there is no data inside it.
I tried to some signature bytes like DEADBEEF in the s->io_buffer and when I dump I see the signature which confirms that the s->io_buffer is not getting the LBA data and the LBA range from domU windows.

My question is , can I know from where the domU filling the s->io_buffer ? So that I can look there to understand why the LBA details are not coming down the way I am expecting ?

On dom-0 from command promt I tried the following experiment

hdpram --trim-range-sector lba:count

lba = 6BYTES of what I got from s->io_buffer
count = 2 BYTES what I got in s->io_buffer
I see the same ata1.00: failed command: DATA SET MANAGEMENT"


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.