[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v6 1/5] xen: move steal_page and donate_page to common code

>>> On 27.09.13 at 18:15, Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx>
> Only code movement, except for a small change to the warning printed in
> case of an error in donate_page.
> Signed-off-by: Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx>
> Acked-by: Ian Campbell <ian.campbell@xxxxxxxxxx>
> CC: keir@xxxxxxx 
> CC: JBeulich@xxxxxxxx 
> Changes in v6:
> - insert a missing black;
> - replace gdprintk with dprintk(XENLOG_G_ in donate_page;
> - replace printk with dprintk(XENLOG_G_ in steal_page;
> - remove casting of page_to_mfn to void*, use %lx instead;
> - add "steal" to the steal_page gdprintk;
> - replace 1 with (-PGC_count_mask & PGC_count_mask) in donate_page.

But the respective comment on the previous version obviously
also applied to steal_page(), where there are still literal 1s left.

Also for readability having something like

#define PGC_count_1 (-PGC_count_mask & PGC_count_mask)

might be worthwhile.

With at least the first part of these changes
Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.