[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [Xen-devel] [PATCH 2/4] opw: libxl: use LOGE instead of LIBXL__LOG_ERRNO in libxl_utils.c
Code cleanup - no functional changes The convenience macro LOGE has been written to take the place of LIBXL__LOG_ERRNO. LOGE depends on the existence of a local libgl__gc *gc. Replace two invocations of LIBXL__LOG_ERRNO, which are in functions that already have a libxl__gc *gc present, to invocations of the new macro. Signed-off-by: Kelley Nielsen <kelleynnn@xxxxxxxxx> Suggested-by: Ian Campbell <Ian.Campbell@xxxxxxxxxx> --- tools/libxl/libxl_utils.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/tools/libxl/libxl_utils.c b/tools/libxl/libxl_utils.c index 4841606..5238f22 100644 --- a/tools/libxl/libxl_utils.c +++ b/tools/libxl/libxl_utils.c @@ -206,14 +206,13 @@ out: static int logrename(libxl__gc *gc, const char *old, const char *new) { - libxl_ctx *ctx = libxl__gc_owner(gc); int r; r = rename(old, new); if (r) { if (errno == ENOENT) return 0; /* ok */ - LIBXL__LOG_ERRNO(ctx, LIBXL__LOG_ERROR, "failed to rotate logfile - could not" + LOGE(ERROR, "failed to rotate logfile - could not" " rename %s to %s", old, new); return ERROR_FAIL; } @@ -247,7 +246,7 @@ int libxl_create_logfile(libxl_ctx *ctx, const char *name, char **full_name) goto out; } else { if (errno != ENOENT) - LIBXL__LOG_ERRNO(ctx, LIBXL__LOG_WARNING, "problem checking existence of" + LOGE(WARN, "problem checking existence of" " logfile %s, which might have needed to be rotated", name); } -- 1.8.1.2 _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |