[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Spice-devel] Vdagent not working on xen linux hvm DomUs

On Fri, Dec 06, 2013 at 02:51:50PM +0100, Fabio Fantoni wrote:
> Il 06/12/2013 14:17, Wei Liu ha scritto:
> >On Fri, Dec 06, 2013 at 02:10:24PM +0100, Fabio Fantoni wrote:
> >[...]
> >>I tried 2 cases with xen_emul_unplug=never:
> >>- with xen platform disabled (xen_platform_pci=0 plus konrad patch)
> >>and pci=nomsi
> >>- with xen_platform_pci=1 and without pci kernel parameter
> >>on both cases qemu crash with same error:
> >>xen_ram_addr_from_mapcache, could not find 0x7fdecf624968
> >>
> >>On your virtio net test you have added only 'model=virtio-net-pci'
> >>on vif line of domU's xl cfg or you did other changes?
> >>
> >No, nothing more. But I'm using Xen's QEMU upstream, not vanilla QEMU.
> I'm using xen's upstream qemu (master of
> git://xenbits.xen.org/qemu-upstream-unstable.git)

Not only the branch is important but also the changeset.

I'm using the hash specified in Config.mk

> >
> >You can probably try to generate core file and use gdb to get the
> >backtrace to see what QEMU is trying to access.
> Is there an howto for it please?

There's lots of tutorial on how configure Linux to let a process be able
to generate core file, how to debug core file with GDB. It's not


> >
> >Wei.
> >
> >>Thanks for any reply.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.