[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Qemu-devel] [PATCH v3 2/4] GlobalProperty: Display warning about unused -global

On 04/19/14 06:56, Fabio Fantoni wrote:

Il 18/04/2014 18:54, Fabio Fantoni ha scritto:

Il 18/04/2014 17:59, Andreas Färber ha scritto:
Am 18.04.2014 17:36, schrieb Fabio Fantoni:
2014-04-18 17:21 GMT+02:00 Andreas Färber <afaerber@xxxxxxx

     Hi Don,

     Am 25.03.2014 00 <tel:25.03.2014%2000>:55, schrieb Don Slutz:
     > This can help a user understand why -global was ignored.
     > For example: with "-vga cirrus"; "-global vga.vgamem_mb=16" is just
     > ignored when "-global cirrus-vga.vgamem_mb=16" is not.
     > This is currently clear when the wrong property is provided:
     > out/x86_64-softmmu/qemu-system-x86_64 -global
     cirrus-vga.vram_size_mb=16 -monitor pty -vga cirrus
     > char device redirected to /dev/pts/20 (label compat_monitor0)
     > qemu-system-x86_64: Property '.vram_size_mb' not found
     > Aborted (core dumped)
     > vs
     > out/x86_64-softmmu/qemu-system-x86_64 -global vga.vram_size_mb=16
     -monitor pty -vga cirrus
     > char device redirected to /dev/pts/20 (label compat_monitor0)
     > VNC server running on `::1:5900'
     > ^Cqemu: terminating on signal 2

I added the cirrus video memory setting in libxl time ago (using -global
vga.vram_size_mb), testing it with qemu 1.3 and also on qemu 1.6 when I
changed from -vga to -device if I remember good.
Has been changed in recent versions or something was not right even
though it seemed right to me?
There are multiple graphics cards to choose from. When using -vga std or
-device vga, then -global vga.foo=bar gets used; if -vga cirrus or
-device cirrus-vga then it needs to be -global cirrus-vga.foo=bar and
any -global vga.foo=bar gets ignored - unless you manage to add it as
secondary (PCI) graphics card.

Thanks for your reply.
Can you tell me if also -device cirrus-vga,vram_size_mb=N is correct and 

I probably found the correct values settable:


in hw/display/cirrus_vga.c:
2988 static Property pci_vga_cirrus_properties[] = {
2989     DEFINE_PROP_UINT32("vgamem_mb", struct PCICirrusVGAState,
2990                        cirrus_vga.vga.vram_size_mb, 8),
2991     DEFINE_PROP_END_OF_LIST(), 36d20cb
2992 };
Than I "-device cirrus-vga,vgamem_mb=N", not show errors and should be correct, 

in hw/display/vga-pci.c:
 182 static Property vga_pci_properties[] = {
183     DEFINE_PROP_UINT32("vgamem_mb", PCIVGAState, vga.vram_size_mb, 16),
186 };
I tried time ago the videoram setting of stdvga on xen but seems was not worked 
(no error but performance remain bad on medium/large resolution, trying kvm 
with same parameters is better), I not know if is vgabios problem or low level 
xen changes are needed.
The mmio option seems new to me, what it is in practice, may need to disable it 
in xen?

Thanks for any reply and sorry for my bad english.

Using qemu 1.7.0, I verified that

   -vga std -global "VGA.vgamem_mb=N


   -vga cirrus -global cirrus-vga.vgamem_mb=N

Correctly set the size of videoram.  Have not checked that 2.0 is still
the same.  I do see:

  -device cirrus-vga -global vga.vram_size_mb=N

In Xen master, which is wrong.

   -Don Slutz

Thanks for any reply.


P.S. Please remember to use text format mails.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.