[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH for-4.5 v9 04/19] xen: Relocate p2m_mem_access_resume to mem_access common



>>> On 24.09.14 at 11:09, <tklengyel@xxxxxxxxxxxxx> wrote:
> Relocate p2m_mem_access_resume to common and abstract the new
> p2m_mem_event_emulate_check into the p2m layer to.
> 
> Signed-off-by: Tamas K Lengyel <tklengyel@xxxxxxxxxxxxx>
> ---
> v9: Pass the vcpu instead of the domain to emulate_check.

Is it correct that you resent just patches 4 and 6 as v9?

> --- a/xen/arch/x86/mm/p2m.c
> +++ b/xen/arch/x86/mm/p2m.c
> @@ -1382,6 +1382,60 @@ static void 
> p2m_mem_event_fill_regs(mem_event_request_t *req)
>      req->x86_regs.cs_arbytes = seg.attr.bytes;
>  }
>  
> +void p2m_mem_event_emulate_check(struct vcpu *v, const mem_event_response_t 
> *rsp)
> +{
> +    /* Mark vcpu for skipping one instruction upon rescheduling. */
> +    if ( rsp->flags & MEM_EVENT_FLAG_EMULATE )
> +    {
> +        struct domain *d = v->domain;
> +        xenmem_access_t access;
> +        bool_t violation = 1;
> +
> +        if ( p2m_get_mem_access(d, rsp->gfn, &access) == 0 )

While it's certainly not wrong, I personally dislike such single use
local variables - you could easily (and without hampering readability)
pass v->domain here.

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel


 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.