[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Booting F21-Alpha-x86 iso image on Xen 4.4 with: io.c:206:d240 MMIO emulation failed @ 0008:ffff245f: 38 7d 2d 3d 02 83 ff ff da 95


Tomorrow is Fedora 21 Alpha test day and I decided to try it
one day earlier. The PV guests install just fine, but to my
surprise the HVM ones crash. It did not matter what kind of
ISO image I put in, it always crashed at:

(d240) HVM Loader
(d240) Detected Xen v4.4.1
(d240) Xenbus rings @0xfeffc000, event channel 3
(d240) System requested SeaBIOS
(d240) CPU speed is 3512 MHz
(d240) Relocating guest memory for lowmem MMIO space disabled
(XEN) irq.c:270: Dom240 PCI link 0 changed 0 -> 5
(d240) PCI-ISA link 0 routed to IRQ5
(XEN) irq.c:270: Dom240 PCI link 1 changed 0 -> 10
(d240) PCI-ISA link 1 routed to IRQ10
(XEN) irq.c:270: Dom240 PCI link 2 changed 0 -> 11
(d240) PCI-ISA link 2 routed to IRQ11
(XEN) irq.c:270: Dom240 PCI link 3 changed 0 -> 5
(d240) PCI-ISA link 3 routed to IRQ5
(d240) pci dev 01:3 INTA->IRQ10
(d240) pci dev 02:0 INTA->IRQ11
(d240) pci dev 04:0 INTA->IRQ5
(d240) No RAM in high memory; setting high_mem resource base to 100000000
(d240) pci dev 03:0 bar 10 size 002000000: 0f0000008
(d240) pci dev 02:0 bar 14 size 001000000: 0f2000008
(d240) pci dev 04:0 bar 30 size 000040000: 0f3000000
(d240) pci dev 03:0 bar 30 size 000010000: 0f3040000
(d240) pci dev 03:0 bar 14 size 000001000: 0f3050000
(d240) pci dev 02:0 bar 10 size 000000100: 00000c001
(d240) pci dev 04:0 bar 10 size 000000100: 00000c101
(d240) pci dev 04:0 bar 14 size 000000100: 0f3051000
(d240) pci dev 01:1 bar 20 size 000000010: 00000c201
(d240) Multiprocessor initialisation:
(d240)  - CPU0 ... 48-bit phys ... fixed MTRRs ... var MTRRs [2/8] ... done.
(d240) Testing HVM environment:
(d240)  - REP INSB across page boundaries ... passed
(d240)  - GS base MSRs and SWAPGS ... passed
(d240) Passed 2 of 2 tests
(d240) Writing SMBIOS tables ...
(d240) Loading SeaBIOS ...
(d240) Creating MP tables ...
(d240) Loading ACPI ...
(d240) vm86 TSS at fc00a080
(d240) BIOS map:
(d240)  10000-100d3: Scratch space
(d240)  e0000-fffff: Main BIOS
(d240) E820 table:
(d240)  [00]: 00000000:00000000 - 00000000:000a0000: RAM
(d240)  HOLE: 00000000:000a0000 - 00000000:000e0000
(d240)  [01]: 00000000:000e0000 - 00000000:00100000: RESERVED
(d240)  [02]: 00000000:00100000 - 00000000:3f800000: RAM
(d240)  HOLE: 00000000:3f800000 - 00000000:fc000000
(d240)  [03]: 00000000:fc000000 - 00000001:00000000: RESERVED
(d240) Invoking SeaBIOS ...
(XEN) io.c:206:d240 MMIO emulation failed @ 0008:ffff245f: 38 7d 2d 3d 02 83 ff 
ff da 95
(XEN) hvm.c:1346:d240 Triple fault on VCPU0 - invoking HVM shutdown action 1.

Which seem to be:

   0:   38 7d 2d                cmp    %bh,0x2d(%rbp)
   3:   3d 02 83 ff ff          cmp    $0xffff8302,%eax
   8:   da                      .byte 0xda
   9:   95                      xchg   %eax,%ebp

If I change the guest config to use QEMU traditional it all works

To make sure it is nothing else but the lowlevel code, I tried
all of this using 'xl' and an simple guest config.

Then I replaced the 'hvmloader' with the one I had built (on F21)
and it worked fine.

Attached is the good and bad 'dmesg' output.  And also the
'readelf -a' output from both hvmloader.

Nothing screams at me as "BUG HERE"..

Attachment: bad
Description: Text document

Attachment: bad.elf
Description: Text document

Attachment: good
Description: Text document

Attachment: good.elf
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.