[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH RFC 18/35] arm : add helper function for setting interrupt type
Hi Parth, On 04/02/2015 14:02, parth.dixit@xxxxxxxxxx wrote: From: Parth Dixit <parth.dixit@xxxxxxxxxx> set edge/level type information for an interrupt Signed-off-by: Parth Dixit <parth.dixit@xxxxxxxxxx> --- xen/arch/arm/irq.c | 19 +++++++++++++++++++ xen/include/asm-arm/irq.h | 4 ++++ 2 files changed, 23 insertions(+) diff --git a/xen/arch/arm/irq.c b/xen/arch/arm/irq.c index 25ecf1d..ae4e99a 100644 --- a/xen/arch/arm/irq.c +++ b/xen/arch/arm/irq.c @@ -545,6 +545,25 @@ int platform_get_irq(const struct dt_device_node *device, int index) return irq; } +#if defined(CONFIG_ARM_64) && defined(CONFIG_ACPI) +int acpi_set_irq(int irq,int type) +{ + int res; + + /* Setup the IRQ type */ + if ( irq < NR_LOCAL_IRQS ) + res = irq_local_set_type(irq, type); + else + res = irq_set_spi_type(irq, type); + + if ( res ) + return -1; + + return 0; + +} +#endif + IIRC Ian was requiring a similar function for PCI. So I would rename to a generic name. Also, now that we start to support ACPI the name of the define DT_IRQ_* are not anymore relevant. Maybe we should rename it. Regards, -- Julien Grall _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |