[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] pvSCSI test

On Friday, February 6, 2015 15:25, Juergen Gross <jgross@xxxxxxxx> wrote:
> To: Kristian Hagsted Rasmussen; Olaf Hering; xen-devel@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Xen-devel] pvSCSI test

>> After some more fiddling around, I believe the configuration should be okay. 
>> My /etc/target/xen-pvscsi_start.sh look like this:
>> modprobe xen-scsiback
>> mkdir /sys/kernel/config/target/xen-pvscsi
>> mkdir -p /sys/kernel/config/target/xen-pvscsi/naa.600140512a981c66/tpgt_0
>> echo naa.6001405708ab297e > 
>> /sys/kernel/config/target/xen-pvscsi/naa.600140512a981c66/tpgt_0/nexus
>> #### xen-pvscsi Target Ports
>> mkdir -p 
>> /sys/kernel/config/target/xen-pvscsi/naa.600140512a981c66/tpgt_0/lun/lun_0
>> ln -s 
>> /sys/kernel/config/target/xen-pvscsi/naa.600140512a981c66/tpgt_0/lun/lun_0/../../../../../../target/core/iblock_0/3_0_0_0
>> /sys/kernel/config/target/xen-pvscsi/naa.600140512a981c66/tpgt_0/lun/lun_0/xen-pvscsi_port
> iblock_0?
Sorry the result is the same if I use pscsi, I just tried iblock as it was a 
harddisk I tried to pass through and lio documentation advice against using 
pscsi for hard drives.

I just now tried to pass through a bluray drive on another machine, however I 
get the exact same error. What I noticed, however, was that the error only 
appears if the DomU kernel supports xen-scsifront. I hazzard a guess that this 
is because the backend only tries to connect to the device if the frontend 
makes a call for it.

In xenstore I have the following entry for vscsi under /local/domain/0/backend:
vscsi = ""
     3 = ""
      0 = ""
       frontend = "/local/domain/3/device/vscsi/0"
       frontend-id = "3"
       online = "1"
       state = "4"
       feature-host = "0"
       vscsi-devs = ""
        dev-0 = ""
         p-dev = "3:0:0:0"
         v-dev = "0:0:0:0"
         state = "6"
       feature-sg-grant = "128"

As I am no expert I am not sure about this, but shouldn't there be a path to 
the device, more then just the p-dev statement?

Do I have to manually add the device to xenstore?

If you do not feel for answering more of my questions please feel free to say 
so, I am just interested in this work and really look forward to its inclusion 
in xen.


> You are not using pscsi, but iblock. Is that on purpose? I have tested
> pscsi and fileio only.
> What does lsscsi tell you after adding the device via targetcli? I
> suppose you see a new scsi target you should use instead of 3:0:0:0
> (that's what I did in the fileio case).
>> #### Attributes for xen-pvscsi Target Portal Group
>> #### Parameters for xen-pvscsi Target Portal Group
>> echo "3:0:0:0" > 
>> /sys/kernel/config/target/xen-pvscsi/naa.600140512a981c66/tpgt_0/param/alias
>> And
>> cat 
>> /sys/kernel/config/target/xen-pvscsi/naa.600140512a981c66/tpgt_0/param/alias
>> returns 3:0:0:0 as expected.
>> If I understand this correctly, it is xen-scsiback that reads the target 
>> configuration from ConfigFS and hence the problem that xen-pvscsi cannot 
>> find the device has nothing to do with which toolstack is used?
> Yes and no. In theory the backend would accept anything from xenstore
> which it can find in configfs. The toolstack however will only write
> values into the xenstore it believes are valid SCSI devices.
>> If you are willing to part with the script you used together with targetcli, 
>> I would be more then happy to try that out.
> I did my first tests with fileio on a machine I have no longer access
> to. after I got it running I changed to my local test machine and pscsi.
> Here I did the targetcli stuff manually and verified afterwards that
> the single steps I put in my script were working. So the script I gave
> you is basically the documentation of the manual setup I used.
> Juergen
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.