[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Compliling Xen 4.5.0 Fails with error: âbufioreq_pfnâ may be used uninitialised in this function [-Werror=uninitialized]


This was originally posted to the user list but it was suggested to me to post 
it here also. I am getting a failed compilation when I try to compile Xen 4.5.0 
from the tarball and also from Git. I can compile RC4, although a bisect 
reveals that they pertinent difference is debug=y in Config.mk, which allows it 
to compile. That compiles without a problem and that is what I am running with. 
I have tried to build on two different servers with the same result, however 
both are running Ubuntu 12.04.5 and are similarly configured.

Steps I (would) use to build are simply...

make dist
make install

which results in...

gcc -O2 -fomit-frame-pointer -m64 -fno-strict-aliasing -std=gnu99 -Wall 
-Wstrict-prototypes -Wdeclaration-after-statement -Wno-unused-but-set-variable  
-DNDEBUG -I/root/xen450/xen-4.5.0/xen/include  
-I/root/xen450/xen-4.5.0/xen/include/asm-x86/mach-default -msoft-float 
-fno-stack-protector -fno-exceptions -Wnested-externs -DHAVE_GAS_VMX 
-DHAVE_GAS_EPT -DHAVE_GAS_FSGSBASE -mno-red-zone -mno-sse -fpic 
-fno-asynchronous-unwind-tables -DGCC_HAS_VISIBILITY_ATTRIBUTE -fno-builtin 
-fno-common -Werror -Wredundant-decls -Wno-pointer-arith -pipe -g -D__XEN__ 
-include /root/xen450/xen-4.5.0/xen/include/xen/config.h -nostdinc -DHAS_ACPI 
-o hvm.o
hvm.c: In function âhvm_create_ioreq_serverâ:
hvm.c:487:18: error: âbufioreq_pfnâ may be used uninitialised in this function 
hvm.c:718:30: note: âbufioreq_pfnâ was declared here
cc1: all warnings being treated as errors
make[5]: *** [hvm.o] Error 1

Any suggestions are welcome,

Thanks for reading,


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.