[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 09/14] libxl: Check xc_domain_maximum_gpfn for negative return values
On Mon, 2015-03-16 at 11:39 -0400, Konrad Rzeszutek Wilk wrote: > Instead of assuming everything is always OK. > > Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> > --- > tools/libxc/xc_core_arm.c | 14 +++++++++++--- > tools/libxc/xc_core_x86.c | 21 +++++++++++++++++---- > tools/libxc/xc_domain_save.c | 8 +++++++- > 3 files changed, 35 insertions(+), 8 deletions(-) > > diff --git a/tools/libxc/xc_core_arm.c b/tools/libxc/xc_core_arm.c > index 34185cf..654692a 100644 > --- a/tools/libxc/xc_core_arm.c > +++ b/tools/libxc/xc_core_arm.c > @@ -31,9 +31,13 @@ xc_core_arch_gpfn_may_present(struct xc_core_arch_context > *arch_ctxt, > } > > > -static int nr_gpfns(xc_interface *xch, domid_t domid) > +static int nr_gpfns(xc_interface *xch, domid_t domid, int *rc) It would be more natural to return the rc directly and update a pointer argument for the max gpfn on success. > diff --git a/tools/libxc/xc_core_x86.c b/tools/libxc/xc_core_x86.c > index b5d442d..426b90d 100644 > --- a/tools/libxc/xc_core_x86.c > +++ b/tools/libxc/xc_core_x86.c > @@ -36,9 +36,13 @@ xc_core_arch_gpfn_may_present(struct xc_core_arch_context > *arch_ctxt, > } > > > -static int nr_gpfns(xc_interface *xch, domid_t domid) > +static int nr_gpfns(xc_interface *xch, domid_t domid, int *rc) Likewise, although perhaps you could consolidate those two into one common wrapper? And then use it everywhere (there were some open-coded ones later on). Or even fix the prototype of xc_domain_maximum_gpfn turning it into said helper, it doesn't look like it has too many callers. Ian. _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |