[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH] tools/libxl new bitmap functions



On Fri, 2015-04-03 at 07:48 -0600, Linda wrote:
> Dario,
>
Hi,

One thing: here in the ML, please, don't top post.

>      I like your comments on naming.  We'll see what others say.
>      As far as difference, at least as I've implemented it, it's the 
> exclusive or.
>
Well, then I'd call it libxl_bitmap_xor().  :-)

BTW, is there an actual use case for it? Intersection and union, I'm
sure they can be useful in many places (I know it from my direct
experience!)... xor, not sure I ever needed it. I'm not complaining or
objecting, I'm just asking. :-D

> To all,
>      I've been thinking about Konrad's comment that we should disallow 
> bitmaps of unequal size, in the XOR/difference function. I've 
> implemented it, so the resulting bitmap is the size of the larger input 
> bitmap, and the bits past the end of the smaller bitmap are all ones.  I 
> think this is inelegant.
>
I don't like this either.

>      Another possibility, is, if two bitmaps are of unequal size, make 
> the XOR bitmap be the size of the smaller bitmap.  This would actually 
> yield a reasonable result.
>      What do others say?
> 
I'm really not sure. This certainly looks at least better than the
solution above, IMO. Another thing that you could do to actually
disallow this is to just return an error if you detect the two bitmaps
have different sizes, but again, I'm not sure... let's see what Wei and
other libxl maintainers (which I'm Cc-ing) think.

Regards,
Dario

> Thanks.
> 
> Linda Jacobson
> 
> 
> On 4/3/2015 3:25 AM, Dario Faggioli wrote:
> > On Thu, 2015-04-02 at 11:38 -0600, Linda Jacobson wrote:
> >> From: Linda <lindaj@xxxxxxxx>
> >>
> >> Added bitmap functions for union intersection and difference betweenn two 
> >> bitmaps
> >>
> > Just wondering, about union and intersection, are them the best names
> > for these operations, or do we want libxl_bitmap_or() and
> > libxl_bitmap_and()?  Personally, I'd go for _and() and _or(), it's more
> > common and more consistent with what we have already in the codebase.
> >
> > About difference, what it the exact intended semantic of that operation?
> > In set theory, AFAICR, A-B is the set of elements that are in A and are
> > not in B. For a binary bitmap, I'd say it is the set of bits that are
> > set in A and are not set in B, is it so? Whatever it is, we should write
> > it down somewhere, e.g., in libxl_utils.h, as the function's doc
> > comment.
> >

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.