[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH Remus v2 03/10] tools/libxc: rename send_some_pages to send_dirty_pages
On 08/05/15 10:33, Yang Hongyang wrote: > rename send_some_pages to send_dirty_pages, no functional change. > > Signed-off-by: Yang Hongyang <yanghy@xxxxxxxxxxxxxx> > --- > tools/libxc/xc_sr_save.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/tools/libxc/xc_sr_save.c b/tools/libxc/xc_sr_save.c > index 2394bc4..9ca4336 100644 > --- a/tools/libxc/xc_sr_save.c > +++ b/tools/libxc/xc_sr_save.c > @@ -379,7 +379,7 @@ static int send_all_pages(struct xc_sr_context *ctx) > * > * Bitmap is bounded by p2m_size. > */ > -static int send_some_pages(struct xc_sr_context *ctx, > +static int send_dirty_pages(struct xc_sr_context *ctx, > unsigned long *bitmap, > unsigned long entries) Please change the parameter alignment, so the end code is properly aligned. Also, you can drop the *bitmap parameter, as it will always be the bitmap found in ctx. This will simplify some of your later patches. ~Andrew > { > @@ -515,7 +515,7 @@ static int send_domain_memory_live(struct xc_sr_context > *ctx) > if ( rc ) > goto out; > > - rc = send_some_pages(ctx, dirty_bitmap, stats.dirty_count); > + rc = send_dirty_pages(ctx, dirty_bitmap, stats.dirty_count); > if ( rc ) > goto out; > } > @@ -540,7 +540,7 @@ static int send_domain_memory_live(struct xc_sr_context > *ctx) > > bitmap_or(dirty_bitmap, ctx->save.deferred_pages, ctx->save.p2m_size); > > - rc = send_some_pages(ctx, dirty_bitmap, > + rc = send_dirty_pages(ctx, dirty_bitmap, > stats.dirty_count + ctx->save.nr_deferred_pages); > if ( rc ) > goto out; _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |