[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v2 04/41] arm/acpi : add arm specific acpi header file
Hi Parth, On 17/05/15 21:03, Parth Dixit wrote: > +#ifndef _ASM_ARM64_ACPI_H > +#define _ASM_ARM64_ACPI_H s/_ASM_ARM64_ACPI_H/_ASM_ARM_ACPI_H/ > + > +#include <xen/init.h> > + > +#define COMPILER_DEPENDENT_INT64 long long > +#define COMPILER_DEPENDENT_UINT64 unsigned long long > + > +extern bool_t acpi_disabled; > +/* Basic configuration for ACPI */ > +static inline void disable_acpi(void) > +{ > + acpi_disabled = 1; > +} It makes a little sense to add the prototype of acpi_disabled without effectively declaring it. Also, the code is very similar to the x86. It would make sense to factorize it (disable_acpi, acpi parameters...) in a common place. > +#endif /*_ASM_ARM_ACPI_H*/ > Regards, -- Julien Grall _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |