[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v3 12/13] x86/altp2m: Add altp2mhvm HVM domain parameter.

On 07/06/2015 10:49 AM, Wei Liu wrote:
>> diff --git a/tools/libxl/libxl_types.idl b/tools/libxl/libxl_types.idl
>> index 23f27d4..66a89cf 100644
>> --- a/tools/libxl/libxl_types.idl
>> +++ b/tools/libxl/libxl_types.idl
>> @@ -437,6 +437,7 @@ libxl_domain_build_info = Struct("domain_build_info",[
>>                                         ("mmio_hole_memkb",  MemKB),
>>                                         ("timer_mode",       
>> libxl_timer_mode),
>>                                         ("nested_hvm",       libxl_defbool),
>> +                                       ("altp2mhvm",        libxl_defbool),
> It's redundant to have "hvm" in the name of this field. Calling it
> "altp2m" would be fine IMHO.

When I originally started writing this code, I modelled the naming
and some of the structure on nestedhvm, which is why so many things
had hvm in the name. I've now removed a lot of those, but in this
instance I wonder if doing so would cause confusion, since we have
a Xen command-line parameter called altp2m.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.