[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Bug-reporting best practice? Xen/Gentoo -- Preparing to log interrupt info sometime after feb. 2016.

Hi all, I'm not a developer but I would like to set up my Xen system to
get bug reports as useful as possible. At present I am logging the xen
console via serial port, and I am running Xen compiled from gentoo
ebuild with "debug" use flag. Is there anything more I need to set up to
be able to collect as much useful info as possible?

At present, this is my xen command line:
xen_commandline        : ssd-xen-debug-marker console_timestamps=date
loglvl=all guest_loglvl=all sync_console iommu=1,verbose,debug
iommu_inclusive_mapping=1 com1=115200,8n1 console=com1 dom0_max_vcpus=4
dom0_vcpus_pin=1 dom0_mem=8G,max:8G cpufreq=xen:performance,verbose
tmem=1 sched_smt_power_savings=1 apic_verbosity=debug e820-verbose=1

(yes, I know, 8G for dom0, well, it is also acting as file server, I
want to keep as much of the file-system in cache as I can )

Any changes I should make for maximally useful bug-reports?

This is in preparation for the 4.7 release (april 2016 I gather) . I
have some PCIe cards that are acting up, something to do with
interrupts. I see some activity on that front right now, so I've decided
to be an early adopter of 4.7, to be able to help as much as possible,
maybe get any tweaks I might need for my system done in the source.

I'm running gentoo, and have tried installing xen-*-9999 from the
virtualization overlay, but it fails, seems it is trying to fetch the
qemu sources twice, and failing.  Is it me doing something wrong? Use
flag "system-qemu" does not help.

Additional info:
The PCIe cards that are acting up are:
00:1b.0 Audio device: Intel Corporation C610/X99 series chipset HD Audio
Controller (rev 05)
02:00.0 USB controller: ASMedia Technology Inc. ASM1042A USB 3.0 Host
81:00.0 USB controller: ASMedia Technology Inc. Device 1242

Trying to pass them through to any domain is highly hit-or-miss. Seems
like interrupt set-up fails quite often, but I have not been able to
find any actual error-messages in any logs. The two first there are
built-in to the motherboard, the last one is an add-in card. I have
tried several other add-in cards for USB, all acting decidedly weird.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.