[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Blank screen while booting xen


I tried to modify and compile some of Xen 4.7's code
(cloned from git clone git://xenbits.xen.org/xen.git)
and even with a very minor change (patch included at last)
my xen failed to boot. It stucks at black blank screen after
showing some xen logs.

By adding "vga=text-80x80,keep" to the grub before booting
xen., infinite loop of text
"(XEN) traps.c:3290: GPF (0000): ffff82d0801af4d5 -> ffff82d080240e5a"

I tried to compile and boot xen reverting the change, but
same issue still exists.

Also I tried to setup serial console but my output is garbled.
More info on it here,

I tried different software (cu, gtkterm), different baud rates,
different serial-USB cable and stopping modemmanager,
but no luck.

I am using i3-6100 processor, if that info is needed.I will
appreciate any help.

Harmandeep Kaur
Outreachy Intern

From c814c4ac0028bdef0082561ad6cd69570502c3ba Mon Sep 17 00:00:00 2001
From: Harmandeep Kaur <write.harmandeep@xxxxxxxxx>
Date: Tue, 29 Dec 2015 22:23:21 +0530
Subject: [PATCH] First mod

Signed-off-by: Harmandeep Kaur <write.harmandeep@xxxxxxxxx>
 xen/common/sched_credit.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/xen/common/sched_credit.c b/xen/common/sched_credit.c
index 0dce790..b395501 100644
--- a/xen/common/sched_credit.c
+++ b/xen/common/sched_credit.c
@@ -1148,6 +1148,8 @@ csched_dom_init(const struct scheduler *ops,
struct domain *dom)
     struct csched_dom *sdom;

+printk("XXX Hello, this is my first mod :) \n");
     if ( is_idle_domain(dom) )
         return 0;

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.