[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Error booting Xen

>>> On 18.01.16 at 19:29, <dario.faggioli@xxxxxxxxxx> wrote:
> On Mon, 2016-01-18 at 18:09 +0000, Andrew Cooper wrote:
>> On 18/01/16 18:03, Harmandeep Kaur wrote:
>> > I tried to boot Xen (cloned from git clone
>> > git://xenbits.xen.org/xen.git), but it stucks
>> > in a infinite loop. I got the log via serial.
>> > You can inspect it at
>> > http://paste2.org/YCpkzbpG 
>> > 
>> > If anybody has encountered this issue
>> > before, I will appreciate any help.
>> Does that last line "(XEN) traps.c:3290: GPF (0000): ffff82d0801af585
>> ->
>> ffff82d080240e5a" repeat forever?
> It does, as far as Harmandeep told me.
> Also, that same Linux kernel binary boots as baremetal.
> ISTR (but, Harmandeep, correct me if I'm wrong) that it was booting
> fine as Dom0, if the Ubuntu packaged version of Xen was used (which I
> think is 4.5).
>> If so, it is a dom0 kernel bug not a Xen bug.
> Yeah, but again, it was booting as dom0 with another Xen... doesn't
> that mean that Xen at least has a role in exposing it?
> Also, what would you think it's better to try next... try another
> kernel?

Figure out what the GP fault that gets recovered from is being
caused by. Then - if indeed it worked on another hypervisor
build - figure out the difference(s) in behavior.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.