[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen domUs seem unable to use one qxl memory bar

Il 24/02/2016 16:44, Fabio Fantoni ha scritto:
Today I was trying a newer version of qxl driver on windows 10 domU (on dom0 with xen 4.6) and I got a windows blue screen about the updated driver.
On latest xl dmesg line I found this error which I suppose is related:
(XEN) memory.c:161:d0v0 Could not allocate order=18 extent: id=53 memflags=0 (0 of 1)
Checking the few commits added in the latest update I found this one:
https://cgit.freedesktop.org/~teuf/qxl-wddm-dod/commit/?id=5df8c4f318d808a8381a948da3ce15b5d4aa6682 Here it starts to use the second qxl memory bar which was unused before in windows qxl drivers FWIK. This additional memory bar is not present in stdvga and if I remember correctly when I started to try qxl vga some years ago I was not able to boot the domUs at all for one or more problem about memory, solved by Jan Beulich and/or Anthony Perard. After such fixes qxl was usable, now I use it even in production windows domUs with monitor resolution up to 1920x1080.

Can someone tell me if the second qxl memory bar is really "unusable" or something, please?
If yes how can it be solved?

Ping...can someone help me please?
I did other test in a testing system with xen 4.6 from git (based on commit 842e19d951c04c99c27a0fa2bca3d1e6cccc77a3) and qemu from qemu-xen master (based on commit 316a862e5534249a6e6d876b4e203342d3fb870e). In this case gave me different xl dmesg output (I suppose for debug feature of new win pv driver), log in attachments.

If you need more information/tests tell me and I'll post them.

Thanks for any reply and sorry for my bad english.

Attachment: xl-dmesg.log
Description: Text document

Attachment: qemu-dm-W10.7z
Description: Binary data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.