[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [V5] x86/xsaves: fix overwriting between non-lazy/lazy xsaves
On Wed, Mar 23, 2016 at 10:02:24AM +0800, Shuai Ruan wrote: > > > - /* Set XSTATE_BV and XCOMP_BV. */ > > > + /* Set XSTATE_BV. */ > > > xsave->xsave_hdr.xstate_bv = xstate_bv; > > > - xsave->xsave_hdr.xcomp_bv = v->arch.xcr0_accum | > > > XSTATE_COMPACTION_ENABLED; > > > setup_xstate_comp(xstate_comp_offsets, xstate_bv); > > > > I see you set xcomp_bv (and hence the compaction bit) in xrstor() > > now, but afaict that doesn't allow you to completely drop initializing > > the field here, as the code there looks at the compaction bit. > > > > > + if ( unlikely(!(ptr->xsave_hdr.xcomp_bv & > > > + XSTATE_COMPACTION_ENABLED)) ) > > > + ptr->xsave_hdr.xcomp_bv = ptr->xsave_hdr.xstate_bv > > > + |XSTATE_COMPACTION_ENABLED; > > > + > > > + XRSTOR("0x48,","0x0f,0xc7,0x1f"); /* xrstors */ > > > + } > > > + else > > > + XRSTOR("0x48,","0x0f,0xae,0x2f"); /* xrstor */ > > > > At this point, what guarantees that xcomp_bv is zero, no matter > > where the state to be loaded originates from? I think at least in > > arch_set_info_guest(), hvm_load_cpu_ctxt(), and > > hvm_vcpu_reset_state() you went too far deleting code, and you > > really need to keep the storing of zero there. Did you draw, just > > for yourself, mentally or on a sheet of paper, a diagram illustrating > > the various state transitions? > > > For above two comments. > > The patch is base on [v4]x86/xsaves: calculate the xstate_comp_offsets base > on xstate_bv and I answer your question on why caculate xstate_comp_offset > based on xstate_bv in previous thread. If that is right, drop > initializing xcomp_bv is ok. Now xcomp_bv can guarantee to be zero for > arch_set_info_guest() and hvm_load_cpu_ctxt(). If the drop is wrong > (due to my misunderstand of the SDM), I will change the if () here. > Ignore the above paragraph, I realized that [v4]x86/xsaves: calculate the xstate_comp_offsets base on xstate_bv is wrong(should be base on xcomp_bv as previous version). Then I should not delete the code initializing the xcomp_bv in compress_xsave_state() But for hvm_vcpu_reset_state(), I think we should deleting the code initializing the xcomp_bv as said below. > For hvm_vcpu_reset_state(), we should depend on whether xsaves is used > to decide whether to init xcomp_bv or not. And currently we use > xcr0_accum to indicate the use of xsaves, when hvm_vcpu_reset_state() > is called , can vcpu->xcr0_accum indicate using of xsaves ? > I think in hvm_vcpu_reset_state(), we should leave xcomp_bv zero. > > > Since again you repeat the same logic twice, this should again have > > been a signal that all your changes should go into the XRSTOR() > > macro. Or alternatively, since the exception fixup also differs, you > > may want to convert the whole logic into an XSAVES and an XSAVE > > path. My only really sincere request here is - as little redundancy as > > possible, since having to change the same thing twice in more than > > one place is always calling for trouble. I will do all changes only in XRSTOR(). Code like : #define _XRSTOR(pfx, xrstor_ins) asm volatile ( "1: .byte " pfx xrstor_ins"\n" \ "3:\n" \ " .section .fixup,\"ax\"\n" \ "2: incl %[faults]\n" \ " jmp 3b\n" \ " .previous\n" \ _ASM_EXTABLE(1b, 2b) \ : [mem] "+m" (*ptr), [faults] "+g" (faults) \ : [lmask] "a" (lmask), [hmask] "d" (hmask), \ [ptr] "D" (ptr) ) #define XRSTOR(pfx) \ if ( v->arch.xcr0_accum & XSTATE_XSAVES_ONLY ) \ { \ if ( unlikely(!(ptr->xsave_hdr.xcomp_bv \ & XSTATE_COMPACTION_ENABLED)) ) \ ptr->xsave_hdr.xcomp_bv |= (ptr->xsave_hdr.xstate_bv \ | XSTATE_COMPACTION_ENABLED); \ _XRSTOR("0x48, ", "0x0f,0xc7,0x1f"); \ } \ else \ { \ _XRSTOR("0x48, ", "0x0f,0xae,0x2f"); \ } .... #undef XRSTOR #undef _XRSTOR A now wapper is intruduced as "_XRSTOR"( maybe the macro name is not good ). > > Xen-devel@xxxxxxxxxxxxx > > http://lists.xen.org/xen-devel > > _______________________________________________ > Xen-devel mailing list > Xen-devel@xxxxxxxxxxxxx > http://lists.xen.org/xen-devel _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |