[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH] monitor: Rename vm_event_monitor_get_capabilities to arch_monitor_get_capabilities



Hi Jan,

On 20/04/16 12:26, Jan Beulich wrote:
Tamas K Lengyel <tamas@xxxxxxxxxxxxx> 04/14/16 6:34 PM >>>
+static inline uint32_t arch_monitor_get_capabilities(struct domain *d)
+{
+    uint32_t capabilities = 0;

Pointless initializer.

+    capabilities = (1U << XEN_DOMCTL_MONITOR_EVENT_GUEST_REQUEST);
+
+    return capabilities;
+}

Even more - the entire function body could be just a single return statement.

Your comments are valid, however this patch is only code movements. If you want the code to be fixed, then it should be a separate patch.

Regards,

--
Julien Grall

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
http://lists.xen.org/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.