[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] question about xl migrate
On 17/05/16 10:01, Zhang, Chunyu wrote: > hi all > > i have two question about xl migrate > > write_batch > 120 for ( i = 0; i < nr_pfns; ++i ) > 121 { > 122 types[i] = mfns[i] = ctx->save.ops.pfn_to_gfn(ctx, > 123 > ctx->save.batch_pfns[i]); > 124 > 125 /* Likely a ballooned page. */ > 126 if ( mfns[i] == INVALID_MFN ) > 127 { > 128 set_bit(ctx->save.batch_pfns[i], ctx->save.deferred_pages); > 129 ++ctx->save.nr_deferred_pages; > 130 } > 131 } > > 1. line 122 > in hvm mode, is not mfns, but gfns. > right? Correct. The array should be named "gfns" rather than "mfns", which is the appropriate term for both PV and HVM guests. > > 2. line 125 > in hvm mode,would not be a balloon page. > gfn would not be INVALID_MFN. > mfn would be INVALID_MFN. > right? I don't understand what you asking here. ~Andrew _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |