[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Bug in x86 instruction emulator?

On 2016-05-18 11:12, Jan Beulich wrote:
On 06.04.16 at 01:38, <wogiz@xxxxxxxxxxxxxxx> wrote:
I'm running Xen 4.6.1 with Alpine Linux 3.3.3 in dom0. In a HVM domU
with vga="qxl", Xorg will segfault instantly if tried started. Multiple
Linux distros have been tested and Xorg segfaults in all.

Attached are a full backtrace from domU generated by Xorg, and a
assembler dump of function 'sse2_blt'.

Just FYI: Looks like I can repro this finally, and it also looks like at
least for me it isn't an SSE2 instruction that the issue is with.
Instead I'm getting an #UD in the middle of an instruction a few
lines down from the last SSE2 one, which suggests we're having
an issue with sizing instructions (however odd that may seem).
Now that I can repro it, at least I have something to actually
debug ...


I have patched Xen 4.6.1 with commit 2bb230972c5ddb1ca823f47750b5d46a9d302d0e (x86emul: suppress writeback upon unsuccessful MMX/SSE/AVX insn emulation) and tested with different Linux distros. I can say with confidence that the patch has solved my initial problem as Xorg no longer segfaults when started. Thanks
to everyone that has helped with this.

However, while testing I have found a new problem. This may not be related to my initial problem or even Xen, but I will try to describe it here as I'm hoping
someone can point me in the right direction.

Various actions will now raise the CPU usage of Xorg to 100% and freeze the
entire X Window System for some time. E.g.:

Starting xterm in a window manager or directly from .xinitrc and executing dmesg. This will print a few lines per second while the Xorg CPU usage is 100% and the X Window System is frozen for about 60 seconds until all dmesg output
has been printed.

I have run 'perf record -g -a sleep 60' while connected via SSH and then
executed dmesg in xterm. I have attached a few lines of 'perf report -g' with
the first one expanded.

I have also run 'strace -p $(pidof Xorg)' while dmesg was running in xterm. The lines I have attached will repeat until all dmesg output has been printed. File
descriptor 8 is pointing on '/dev/dri/card0'.

Any ideas on what could cause this?

William Z.

Attachment: perf_report.txt
Description: Text document

Attachment: strace.txt
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.