[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v6 06/14] xen: Move the hvm_start_info C representation from libxc to public/xen.h
On 12/07/16 15:42, Anthony PERARD wrote: > +#ifndef __XEN_PUBLIC_ARCH_X86_HVM_START_INFO_H__ > +#define __XEN_PUBLIC_ARCH_X86_HVM_START_INFO_H__ > + > +/* > + * C representation of the x86/HVM start info layout. > + * > + * The canonical definition of this layout resides in public/xen.h, this You should also move the big comment block from public/xen.h to here, along with the XEN_HVM_START_MAGIC_VALUE define. There is no point having it split across two locations in the public headers. ~Andrew > + * is just a way to represent the layout described there using C types. > + * > + */ > +struct hvm_start_info { > + uint32_t magic; /* Contains the magic value 0x336ec578 > */ > + /* ("xEn3" with the 0x80 bit of the "E" > set).*/ > + uint32_t version; /* Version of this structure. > */ > + uint32_t flags; /* SIF_xxx flags. > */ > + uint32_t nr_modules; /* Number of modules passed to the kernel. > */ > + uint64_t modlist_paddr; /* Physical address of an array of > */ > + /* hvm_modlist_entry. > */ > + uint64_t cmdline_paddr; /* Physical address of the command line. > */ > + uint64_t rsdp_paddr; /* Physical address of the RSDP ACPI data > */ > + /* structure. > */ > +}; > + > +struct hvm_modlist_entry { > + uint64_t paddr; /* Physical address of the module. > */ > + uint64_t size; /* Size of the module in bytes. > */ > + uint64_t cmdline_paddr; /* Physical address of the command line. > */ > + uint64_t reserved; > +}; > + > +#endif /* __XEN_PUBLIC_ARCH_X86_HVM_START_INFO_H__ */ _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |