[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 8/9] tmem/xc_tmem_control: Rename 'arg1' to 'len' and 'arg2' to arg.

On 30/09/16 19:11, Konrad Rzeszutek Wilk wrote:
> That is what they are used for. Lets make it more clear.
> Of all the various sub-commands, the only one that needed
> semantic change is XEN_SYSCTL_TMEM_OP_SAVE_BEGIN. That in the
> past used 'arg1', and now we are moving it to use 'arg'.
> Since that code is only used during migration which is tied
> to the toolstack it is OK to change it.
> We should increment the XEN_SYSCTL_INTERFACE_VERSION because
> of this, and that was fortunatly done in the patch titled:
> "tmem/libxc: Squash XEN_SYSCTL_TMEM_OP_[SET|SAVE].."
> While at it, also fix xc_tmem_control_oid to properly handle
> the 'buf' and bounce it as appropiate.
> Acked-by: Wei Liu <wei.liu2@xxxxxxxxxx>
> Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>

Acked-by: Andrew cooper <andrew.cooper3@xxxxxxxxxx>

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.