[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 01/15] x86/hvm: Rename hvm_emulate_init() and hvm_emulate_prepare() for clarity



 >>> On 23.11.16 at 16:38, <andrew.cooper3@xxxxxxxxxx> wrote:
> * Move hvm_emulate_init() to immediately hvm_emulate_prepare(), as they are
>    very closely related.
>  * Rename hvm_emulate_prepare() to hvm_emulate_init_once() and
>    hvm_emulate_init() to hvm_emulate_init_per_insn() to make it clearer how to
>    and when to use them.
> 
> No functional change.
> 
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>

Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx>
with one further cosmetic request:

> @@ -2006,6 +1956,57 @@ void hvm_emulate_prepare(
>      hvmemul_get_seg_reg(x86_seg_ss, hvmemul_ctxt);
>  }
>  
> +void hvm_emulate_init_per_insn(
> +    struct hvm_emulate_ctxt *hvmemul_ctxt,
> +    const unsigned char *insn_buf,
> +    unsigned int insn_bytes)
> +{
> +    struct vcpu *curr = current;
> +    unsigned int pfec = PFEC_page_present;
> +    unsigned long addr;
> +
> +    if ( hvm_long_mode_enabled(curr) &&
> +         hvmemul_ctxt->seg_reg[x86_seg_cs].attr.fields.l )
> +    {
> +        hvmemul_ctxt->ctxt.addr_size = hvmemul_ctxt->ctxt.sp_size = 64;
> +    }

Please consider dropping the stray braces here.

Jan


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
https://lists.xen.org/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.